Gentoo Linux Security Advisory 202003-06 ≈ Packet Storm


– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Gentoo Linux Security Advisory GLSA 202003-06
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
https://security.gentoo.org/
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Severity: Normal
Title: Ruby: Multiple vulnerabilities
Date: March 13, 2020
Bugs: #696004
ID: 202003-06

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Synopsis
========

Multiple vulnerabilities have been found in Ruby, the worst of which
could lead to the remote execution of arbitrary code.

Background
==========

Ruby is an interpreted object-oriented programming language. The
elaborate standard library includes an HTTP server (« WEBRick ») and a
class for XML parsing (« REXML »).

Affected packages
=================

——————————————————————-
Package / Vulnerable / Unaffected
——————————————————————-
1 dev-lang/ruby < 2.4.9:2.4 >= 2.4.9:2.4
< 2.5.7:2.5 >= 2.5.7:2.5

Description
===========

Multiple vulnerabilities have been discovered in Ruby. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could execute arbitrary code, have unauthorized
access by bypassing intended path matching or cause a Denial of Service
condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Ruby 2.4.x users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose « >=dev-lang/ruby-2.4.9:2.4 »

All Ruby 2.5.x users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose « >=dev-lang/ruby-2.5.7:2.5 »

References
==========

[ 1 ] CVE-2019-15845
https://nvd.nist.gov/vuln/detail/CVE-2019-15845
[ 2 ] CVE-2019-16201
https://nvd.nist.gov/vuln/detail/CVE-2019-16201
[ 3 ] CVE-2019-16254
https://nvd.nist.gov/vuln/detail/CVE-2019-16254
[ 4 ] CVE-2019-16255
https://nvd.nist.gov/vuln/detail/CVE-2019-16255

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202003-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users’ machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons – Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



Source link

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *