Gentoo Linux Security Advisory 202003-48 ≈ Packet Storm


– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Gentoo Linux Security Advisory GLSA 202003-48
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
https://security.gentoo.org/
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Severity: Normal
Title: Node.js: Multiple vulnerabilities
Date: March 20, 2020
Bugs: #658074, #665656, #672136, #679132, #702988, #708458
ID: 202003-48

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Synopsis
========

Multiple vulnerabilities have been found in Node.js, worst of which
could allow remote attackers to write arbitrary files.

Background
==========

Node.js is a JavaScript runtime built on Chrome’s V8 JavaScript engine.

Affected packages
=================

——————————————————————-
Package / Vulnerable / Unaffected
——————————————————————-
1 net-libs/nodejs < 12.15.0 >= 10.19.0
>= 12.15.0

Description
===========

Multiple vulnerabilities have been discovered in Node.js. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly write arbitrary files, cause a Denial
of Service condition or can conduct HTTP request splitting attacks.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Node.js <12.x users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose « >=net-libs/nodejs-10.19.0 »

All Node.js 12.x users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose « >=net-libs/nodejs-12.15.0 »

References
==========

[ 1 ] CVE-2018-12115
https://nvd.nist.gov/vuln/detail/CVE-2018-12115
[ 2 ] CVE-2018-12116
https://nvd.nist.gov/vuln/detail/CVE-2018-12116
[ 3 ] CVE-2018-12121
https://nvd.nist.gov/vuln/detail/CVE-2018-12121
[ 4 ] CVE-2018-12122
https://nvd.nist.gov/vuln/detail/CVE-2018-12122
[ 5 ] CVE-2018-12123
https://nvd.nist.gov/vuln/detail/CVE-2018-12123
[ 6 ] CVE-2018-7161
https://nvd.nist.gov/vuln/detail/CVE-2018-7161
[ 7 ] CVE-2018-7162
https://nvd.nist.gov/vuln/detail/CVE-2018-7162
[ 8 ] CVE-2018-7164
https://nvd.nist.gov/vuln/detail/CVE-2018-7164
[ 9 ] CVE-2018-7167
https://nvd.nist.gov/vuln/detail/CVE-2018-7167
[ 10 ] CVE-2019-15604
https://nvd.nist.gov/vuln/detail/CVE-2019-15604
[ 11 ] CVE-2019-15605
https://nvd.nist.gov/vuln/detail/CVE-2019-15605
[ 12 ] CVE-2019-15606
https://nvd.nist.gov/vuln/detail/CVE-2019-15606
[ 13 ] CVE-2019-16777
https://nvd.nist.gov/vuln/detail/CVE-2019-16777
[ 14 ] CVE-2019-5737
https://nvd.nist.gov/vuln/detail/CVE-2019-5737
[ 15 ] CVE-2019-5739
https://nvd.nist.gov/vuln/detail/CVE-2019-5739

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202003-48

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users’ machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons – Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



Source link

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *