Gentoo Linux Security Advisory 202003-57 ≈ Packet Storm


– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Gentoo Linux Security Advisory GLSA 202003-57
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
https://security.gentoo.org/
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Severity: High
Title: PHP: Multiple vulnerabilities
Date: March 26, 2020
Bugs: #671872, #706168, #710304, #713484
ID: 202003-57

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Synopsis
========

Multiple vulnerabilities have been found in PHP, the worst of which
could result in the execution of arbitrary shell commands.

Background
==========

PHP is an open source general-purpose scripting language that is
especially suited for web development.

Affected packages
=================

——————————————————————-
Package / Vulnerable / Unaffected
——————————————————————-
1 dev-lang/php < 7.4.4 *>= 7.2.29
*>= 7.3.16
*>= 7.4.4

Description
===========

Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.

Impact
======

An attacker could possibly execute arbitrary shell commands, cause a
Denial of Service condition or obtain sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP 7.2.x users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose « >=dev-lang/php-7.2.29 »

All PHP 7.3.x users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose « >=dev-lang/php-7.3.16 »

All PHP 7.4.x users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose « >=dev-lang/php-7.4.4 »

References
==========

[ 1 ] CVE-2018-19518
https://nvd.nist.gov/vuln/detail/CVE-2018-19518
[ 2 ] CVE-2020-7059
https://nvd.nist.gov/vuln/detail/CVE-2020-7059
[ 3 ] CVE-2020-7060
https://nvd.nist.gov/vuln/detail/CVE-2020-7060
[ 4 ] CVE-2020-7061
https://nvd.nist.gov/vuln/detail/CVE-2020-7061
[ 5 ] CVE-2020-7062
https://nvd.nist.gov/vuln/detail/CVE-2020-7062
[ 6 ] CVE-2020-7063
https://nvd.nist.gov/vuln/detail/CVE-2020-7063
[ 7 ] CVE-2020-7064
https://nvd.nist.gov/vuln/detail/CVE-2020-7064
[ 8 ] CVE-2020-7065
https://nvd.nist.gov/vuln/detail/CVE-2020-7065
[ 9 ] CVE-2020-7066
https://nvd.nist.gov/vuln/detail/CVE-2020-7066

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202003-57

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users’ machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons – Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5



Source link

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *