Ubuntu Security Notice USN-4321-1 ≈ Packet Storm


=========================================================================
Ubuntu Security Notice USN-4321-1
April 07, 2020

haproxy vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 19.10
– Ubuntu 18.04 LTS

Summary:

HAProxy could be made to execute arbitrary code if it received a specially crafted HTTP/2 request.

Software Description:
– haproxy: fast and reliable load balancing reverse proxy

Details:

Felix Wilhelm discovered that HAProxy incorrectly handled certain HTTP/2 requests.
An attacker could possibly use this to execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.10:
haproxy 2.0.5-1ubuntu0.4

Ubuntu 18.04 LTS:
haproxy 1.8.8-1ubuntu0.10

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4321-1
CVE-2020-11100

Package Information:
https://launchpad.net/ubuntu/+source/haproxy/2.0.5-1ubuntu0.4
https://launchpad.net/ubuntu/+source/haproxy/1.8.8-1ubuntu0.10



Source link

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.